ZFS and Leopard Part I

bash-3.2# uname -a
Darwin vintage.local 9.0.0 Darwin Kernel Version 9.0.0: Tue Oct 9 21:37:58 PDT 2007; root:xnu-1228~1/RELEASE_PPC Power Macintosh
bash-3.2# date
среда, 31 октября 2007 г. 21:29:58 (MSK)
bash-3.2# zpool import
pool: supportpool
id: 6185478332692909751
state: FAULTED
status: The pool is formatted using an incompatible version.
action: The pool cannot be imported. Access the pool on a system running newer
software, or recreate the pool from backup.
see: http://www.sun.com/msg/ZFS-8000-A5
config:

supportpool UNAVAIL newer version
disk1 ONLINE
bash-3.2#

Слизали , сукины дети 😉 Версия пула – 8 в опенсолярисе . А вот версия пула из Solaris 8/07 слишком старая с точки зрения MacOSX – предлагает делать upgrade – но , увы , нечем ;| ReadOnly ВСЕ !
А между тем поиск по строке “ZFS” на ADC начал выдавать кое-какие результаты 😉 – ссылка на поиск – буквально вчера было “0 Results Found” .
Еще одно уточнение – используется 6-я версия пула ZFS – http://www.opensolaris.org/os/community/zfs/version/6/ .

Leave a Reply