NB: Проблемы с производительностью линейки ProApps (Aperture/FinalCut) (и не только) на 10.6.4

Чтобы случилось непоправимое, нам нужно:

  • Aperture (2.0, 3.0 – не важно), либо Final Cut (версию не знаю), либо (сюрприз!) Safari/Chromium/Chrom с Adobe Flash Player 10.1 (с этим приложением эффект проявляется существенно медленнее во времени), либо игрушка из Steam.
  • видеокарта NVidia (любая из современной линейки)
  • Combo Update 10.6.4
  • необъяснимые проблемы с производительностью, приводящие к принудительной перезагрузке либо сильной деградации

То надо жать на кнопку и смотреть, что я “накорябал” дальше…
Итак, сама проблема: запускаем Апертуру (3.0.3), выбираем фотографию, дожидаемся, когда исчезнет надпись Loading… . Машина становиться “колом” – то есть:

  • с трудом переключаемся между окошками
  • мышь произвольно дергается в процессе загрузки фотографий
  • фактически неработоспособно приложение Terminal.app (и иже с ним тому подобные – iTerm.app – мой случай)
  • Activity Monitor.app/top/vm_stat/MenuMeters НЕ выявляют ЯВНЫХ проблем – нет ни видимых глазом утечек памяти, sys/usr не растет, idle – не падает, количество page in/out – в норме, своп не растет (вообще не используется)
  • разнообразные методы отладки (Perfomance Tools/Quartz Debug, Malloc Debug) – НЕ выявляют явных проблем
  • дисковая активность сохраняется на обычном уровне
  • любое (почти, почти любое) “старое” OpenGL приложение НЕ испытывает проблем с производительностью (в моем случае – случайно убедился в этом с помощью Quake 2 😉 )
  • ненормально поддтормаживает прокрутка в браузерах (у меня и в Safari, и в Chromium)
  • ненормально поддтормаживает прокрутка в почтовых клиентах (Mail.app)
  • никакие танцы с бубном не дают видимых результатов (Repair Permission, SMC Reset, Safe Boot, Cache cleanup, etc.,etc.,etc.)

Выход из ситуации – только перезагрузка. Достало и надоело.

Небольшое описание проблемы (одно из) – чужое, не мое: http://discussions.apple.com/thread.jspa?threadID=24…rt=0&tstart=0

Если Вы имеете похожие проявления, то приступаем к проверке:

  • запускаем Terminal.app
  • запускаем команду sw_vers

…либо…

  • нажимаем в левом/верхнем углу Яблоко/About This Mac

… и видим там версию 10.6.4 – у нас однозначная проблема.

Все-таки запускаем терминал, даем команду:

kextstat | egrep "NVDANV50Hal|NVDANV40Hal|NVDAResman|GeForce|GeForceVADriver|GeForceGLDriver|GeForce7xxxGLDriver|GeForceGA|NVSMU"
 91    2 0x5ce28000 0x2e1000   0x2e0000   com.apple.NVDAResman (6.1.6) <90 81 14 5 4 3 1>
 101    0 0x5c401000 0xac000    0xab000    com.apple.GeForce (6.1.6) <91 90 81 14 7 6 5 4 3 1>

…и видим версию 6.1.6 – это и есть наше проблемное место…

Путей решения проблемы – два: 1) переустановка системы и последующий “накат” обновления 10.6.3 Combo Update version 1.1 БЕЗ последующего наката 10.6.4 с надеждой на фикс проблемы в 10.6.5 или 2) подмена драйверов NVidia на версию 6.1.0 из 10.6.3 Combo Update.

Я пошел по второму пути – если надо, распишу подробнее, как извлечь из архива нужные файлы и что сделать дальше, либо (что проще) дам готовый файл с архивом драйверов.

После замены драйверов – кеши не чистил, SMC не сбрасывал – просто запустил систему, которая заработала ПОЛНОСТЬЮ нормально.

Уже во второй раз говорю “СПАСИБО” шакалам из Apple, которые даже не проверяют, что именно они выпускают в продуктив. Проблему воспроизвел на ДВУХ не самых старых ноутбуках – в два шага (Software Update -> Install). В этот раз даже не стал пытаться обращаться в техподдержку Apple – прошлые пляски с USB и 10.6.3 не привели хоть к какому-нибудь вменяемому результату. Это, судя по всему, становиться нормой для Apple – что очень печально для такой интересной компании.

PS: Что-то не то в Apple происходит – масса проблем после установки с ProApps, и на маленьких машинах, и на больших – с выходом 10.6.3 – они плотно начались, в 10.6.4 – грабли стали такими, что работать на старенькой машинке mbp 15 и aperture больше невозможно 🙁

PPS: я, конечно, понимаю, что сейчас набегут товарищи, которые скажут однозначно – “НЕТ НИКАКОЙ ПРОБЛЕМЫ, потому как я не видел и не слышал” – сразу оговариваюсь – я буду в упор игнорить такое – задача стоит не ОБОСРАТЬ Apple как таковой, а просто обратить внимание на непростую проблему с производтельностью, которая однозначно есть у некоторых пользователей (я абсолютно уверен в этом – получен количественный результат, который и перешел в качественный в виде этого поста) и также обратить внимание на то, что качество ПО от Apple последнее время несколько, ммм, скажем так – ухудшилось.

PPPS: обратите внимание на еще одну “забаву”:

  • 15 июня выпущен Combo Update 10.6.4 – вопросов нет, все его долго ждали (в тч и я)
  • 27 июля выпущен Combo Update 10.6.4 for iMac – а в нем любопытная запись – “Resolves compatibility and performance-related graphics issues”

Как бы наводит на кое-какие мысли о “качестве” обновлений – даже на самой свежей линейке фактическое тестирование не проводится?!

Leave a Reply